Ai 7.1 BETA

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Ai 7.1 BETA

Post  Dave on Thu Nov 21, 2013 7:46 am

Hi Folks.

Here is a link to download the first BETA release of Ai 7.1

http://aiforum.forumotion.co.uk/t166-ai-v71-beta#653

I thought I should bring you all up to date on exactly what is in it..

The final release version of 7.1 will be launched on the AvolitesMedia.com website once we have ironed any bugs out from this 7.1 BETA, brought the manual up to date with the 7.1 changes and we have brought the OSX version up to date, all of which we are planning to do in the coming weeks.  There is no further functionality planned for 7.1 now other than what is detailed below.  Any other feature requests and new functionality will be planned into our version 8 release which we are planning to have an early version of by Frankfurt (March 2014) with a full version release hopefully ready by around May 2014

There are lots of nice changes in 7.1 which we will attempt to detail below.

'Roller Cue' Superseded by 'Media Tiles'


So the Roller Cue was a labour of love for me around a year ago when I first designed it and it still has a special place in my heart, but it had to go.  As fun as it was it had a couple of drawbacks.  Firstly it had a performance impact on the Performance Page which was un-acceptable, many users were finding themselves running the system on the Stage Construction page or closing the interface altogether in order to get the performance they required on their project.  Secondly it didn't work very well with Touch screens and triggers would sometimes randomly be missed, both of these facts were obviously un acceptable going forward.


The performance hit was due a number of factors, but primarily due to some off screen rendering required in order to interpret mouse location on a 2D surface (your screen) overlaid on a 3D object (the roller cue).  Much optimisation of this has been tried over the last few months and it seems that although Nvidia cards were much more tolerant of the issues the AMD cards in our systems just didn't perform well whilst reading back the off screen rendered data from the card.  This seems to have been further compounded by optimisations in the latest W series driver required for the next generation hardware we're about to release.  So the decision was made to re-write the entire roller cue triggering interface into a much leaner and high performance version which we're calling 'Media Tiles'.  The good news is that we now have a far superior triggering interface with much better performance and a lot more functionality.  I am pleased to say that the performance page is now just as fast as the stage construction page in all the projects I have tested with so far.
Media Tiles


So essentially the look is similar to the Roller Cue, except there is no 3d cylinder for the clips to 'sit on'.  Clips that you drag in from explorer now just float in the performance page and tessellate nicely together into whatever shape you choose to make.  The concept is similar to the old Hexagon Cluster that many of you may remember from Version 6 and earlier, except with 16:9 rectangles instead of hexagons.  Also we now have the nice right click to edit clip properties thing which was introduced along with the Roller Cue.  Here is some further info on some of the additional functionality in 'Media Tiles'.

o Stored as banks - should hopefully be backwards compatible with banks made for the roller cue.
o Dragged in clips Snap to adjacent tiles
o Multi-select cells using a click and drag rectangle near to tiles dragged over multiple tiles.  Also shift click and ctrl A will multi select.
o Mouse scroll wheel zooms in and out of media tiles. 
o Click and drag tiles moves tiles into any area of the UI you wish to place them in.
o Drag and drop folders of clips in, or multi selected clips.
o Alt click and drag tiles (or ctrl X) will move them around (works with multi selected clips too).
o Ctrl C and move mouse will copy tiles (works with multi selected clips too).
o Right click tile to zoom to clip properties
o Arrow keys to navigate tile grid
o New lower dock site - move & copy and paste tiles to the bottom of the screen to line them up with Sapphire Media Faders or just to group them ready to be triggered manually.
o New 'Always on Top' triggering method when using the Sapphire Media / MSC-1 template project to cue Media from the lower dock site with the Sapphire Media - very nice way to busk live shows.

o Follow on actions in clip properties.  Allows users to set what happens when a clip finishes.  Current follow on actions include 'next', 'prev', 'left', 'right', 'up', 'down', 'first', 'last', 'goto___' & 'random'. Note follow on action will be triggered at the beginning of the cross fade period to ensure cross fades are automated correctly. 
Infinity Server Rear Connectors


I am pleased to report that the rear panel connectors on the infinity servers will now be fully functional with systems running this 7.1 release.  This includes LTC Timecode, DMX Output & Midi Input & Output.  The DMX outputs appear in the Artnet modules as adapter 1.2.3.4 which is now one of the options in the drop down list.  The midi input and output device appears in the midi modules as AiMidi.  The LTC support is now select-able in the system settings in the Midi Panel.
Updated Time Code functionality


New or updated entries on the Midi Panel in the System Settings include:

Use LTC TimeCode - can be set to either 'Using MTC' or 'Using LTC' - Please note that LTC is only functional on the Avolites Media Infinity server and S4/S6 systems.
Free Wheel TimeCode - can be set to Disabled or Active - this sets whether timecode triggering pauses or free runs when incoming time code is stopped or vanishes.

Use System Clock as TC - can be set to Disabled or Active - this allows the use to use the windows system clock as a time code source allowing you to trigger media at certain times of the day.  This will override MTC or LTC.
Added the Opti track module 


Added NatNet Client Module. Which allows you to stream rigid body tracking data from Motive (NaturalPoint's proprietary software) into Ai through a network interface.  This allows for you to track multiple 3D objects using the OptiTrack functionality in 6 degrees of freedom.
Calender Trigger Module 


For triggering events on certain dates and times
Added Shader Example Patches 


Including some nice Audio Reactive patches, all sourced from ShaderToy.com - very cool - check it out.
Added a String to Number module


Converts a text string into a number
Buffered Constant Select module


New module which takes in multiple values and outputs one value, looking for changes or the last value to be entered. This ignores zeros so if you are listening for a trigger and get that trigger briefly, this module will latch that value and keep that as the output until it receives a new value or has been reset. Because it also looks for changes if you constantly send the same value it will be ignored when looking for updates from other ports.
EDID list fixed for the Infinity servers


All Infinity EDID files shipped in the EDID Pool have been closely examined and changed, where before some were causing BSOD because of some corruptions to the registry. If a resolution is not supported by the graphics cards, then that EDID file has also been removed to improve stability.
Fixed Audio keeps playing from previous clip when still image is triggered

Fixed midi mapping of projector fixture next/prev object, vertex, screen

RFID tag support
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  Dave on Fri Nov 22, 2013 4:22 am

OSX version is up there now too.  Please let me know if you find any issues.  Thanks!
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  Sebastien on Fri Nov 22, 2013 6:23 am

When I start a new project, I try to put a name and the "u" letter is not working but just the "u".

Sebastien

Posts : 137
Join date : 2013-02-28
Age : 34
Location : France

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  PatrickBEL on Fri Nov 22, 2013 7:45 am

Same problem here with the 'u' button

PatrickBEL

Posts : 10
Join date : 2013-06-26

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  Dave on Fri Nov 22, 2013 5:19 pm

OK Thanks for pointing this out.  I know what the problem is.. I'll try to fix this today and update the beta download.

Best regards
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  Dave on Fri Nov 22, 2013 9:57 pm

Some more updates:

DONE - edit artnet map only works for universe 0
DONE - OSX Artnet support
DONE - letter u and d don't work in dialog boxes
DONE - ctrl plus up or down arrow on performance page shifts all layers up or down
DONE - option to flip layer rendering order in System Settings/General/Layer render order - Top to Bottom or Bottom to Top

I have updated both Windows and OSX BETA versions on the downloads page:

http://aiforum.forumotion.co.uk/t166-ai-v71-beta#653
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  Dave on Tue Nov 26, 2013 12:27 am

Hi Folks

Heres a few further updates:

DONE - Performance boost on output module (removed unneccesary SetGLBlend)
DONE - Fixed MSC1 DMX outputs
DONE - Improved performance of the Canvas Editor Page on complex models
DONE - Added texture output port to every layer inside mixer for easy direct access to a layers texture
DONE - Fixed bug with 3DS output module using obj's not displaying
DONE - Renamed and reordered the first three options in the general tab of system settings to refer to the roller cue

I have updated both Windows and OSX BETA versions on the downloads page:

http://aiforum.forumotion.co.uk/t166-ai-v71-beta#653

Let me know if there are still any issues?

Thanks!
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  pepiha83 on Tue Dec 03, 2013 5:41 am

Hi!

Is there any possibility to close the opengl video output when it is patched to the first screen with stage patch window? The only option i ve found was to kill the AI process via ssh and lan access. (MAC OS 10.9 and actual beta release).
Thanks!
Josef

pepiha83

Posts : 17
Join date : 2013-12-03
Location : Austria

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Tue Dec 03, 2013 8:04 am

do you get the same problem on OSX 10.7 / 8 ? ( if you dont have the option to try it on there, can you forward me the project and i can try it on 10.7 )

we havnt tested Ai for 10.9 yet ( although id generaly reccomend against Mavericks if possible at the moment )
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

Re: Ai 7.1 BETA

Post  pepiha83 on Wed Dec 04, 2013 12:33 am

OK, i´ll test it on 10.8 today evening and windows 7. Testing on version 10.7 is not possible for me. It´s not a project specific problem, the problem exists with the demo projects too.
Thanks!

pepiha83

Posts : 17
Join date : 2013-12-03
Location : Austria

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  pepiha83 on Wed Dec 04, 2013 8:07 am

Problem found (and solved). It was a permission problem. Since i´ve changed the permissions from the user running AI, all is working like expected Smile

pepiha83

Posts : 17
Join date : 2013-12-03
Location : Austria

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  Sebastien on Tue Dec 10, 2013 9:27 pm

I just try the last release of Ai (7.1.455) and the software look a lot more heavy. The video are not so smooth compare to the 7.0.1760.
And for me the inframe and Outframe points are not working. I mean you can run 10 times the video and 10 times the Inpoint and Outpoint will be different...

Thank You

Sebastien

Posts : 137
Join date : 2013-02-28
Age : 34
Location : France

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  gazzer82 on Fri Jan 03, 2014 10:29 pm

I am getting a lot of crashes running the latest beta on a Macbook Pro (Just trying to build my stage)

It seems to happen very early on when changing the position of the screen fixture, here is a section of the crash log.

Thread 8 Crashed:
0 com.yourcompany.Salvation 0x00d3356e SVString::ToCString() const + 12
1 com.yourcompany.Ai 0x00232925 AiGUIToolTipsModule::DrawToolTips(IGLRenderContext&) + 229
2 com.yourcompany.Ai 0x00233bf7 non-virtual thunk to AiGUIToolTipsModule::Render(IGLRenderContext&, SVRenderTime) + 29
3 com.yourcompany.Salvation 0x00ace83b GLGuiControlContainerBase::RenderContents(int, IGLRenderContext&, SVRenderTime) + 943
4 com.yourcompany.Salvation 0x00acf3b3 GLGuiControlContainerBase::Render(IGLRenderContext&, SVRenderTime) + 989
5 com.yourcompany.Salvation 0x00ad0158 non-virtual thunk to GLGuiControlContainerModule::Render(IGLRenderContext&, SVRenderTime) + 84
6 com.yourcompany.Salvation 0x00ad453e GLDisplayModuleClass::RenderInput(IGLRenderContext&, SVRenderTime) + 118
7 com.yourcompany.Salvation 0x00ad45ea GLDisplayModuleClass::Render(IGLRenderContext&, SVRenderTime) + 140
8 com.yourcompany.Salvation 0x00ccbe05 GLDisplayModuleClass::Render(ISVRenderContext&) + 125
9 com.yourcompany.Salvation 0x00ad5711 non-virtual thunk to GLDisplayModuleClass::Render(ISVRenderContext&) + 27
10 com.yourcompany.Salvation 0x00c4c87a OpenGLRenderScreen::RenderInput(SVRenderTime) + 100
11 com.yourcompany.Salvation 0x00c45648 SVOpenGLRenderInterface::private_RenderOneFrame(double&) + 1030
12 com.yourcompany.Salvation 0x00c45fb8 SVOpenGLRenderInterface::private_RenderThread() + 262
13 com.yourcompany.Salvation 0x00c45eab SVOpenGLRenderInterface::private_ThreadEntry(void*) + 21
14 com.yourcompany.Salvation 0x00c6532d pthreadentry(void*) + 109
15 libsystem_c.dylib 0x9601f5b7 _pthread_start + 344
16 libsystem_c.dylib 0x96009dce thread_start + 34

Any ideas, it's somewhat ruining my initial impressions of Ai . . .

Thanks

Gareth

gazzer82

Posts : 15
Join date : 2013-12-06

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Fri Jan 03, 2014 10:49 pm

what is the specification of your macbook? which OS are you using?
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

Re: Ai 7.1 BETA

Post  gazzer82 on Fri Jan 03, 2014 11:12 pm

It is the 2.4Ghz Retina Macbook Pro, 8GB Ram

OS is 10.8.5

Thanks for the swift reply.

Cheers

Gareth

gazzer82

Posts : 15
Join date : 2013-12-06

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  gazzer82 on Mon Jan 06, 2014 10:31 pm

Did you get a chance to look at this yet, it's quite a regular and reproducible crash, it also seems to do it at a similar regularity on a different system hardware wise.

Thanks

Gareth

gazzer82

Posts : 15
Join date : 2013-12-06

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Wed Jan 08, 2014 10:26 pm

a new build is currently being worked upon to be released very soon Smile
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

Re: Ai 7.1 BETA

Post  benjo09 on Sat Jan 11, 2014 10:22 am

gazzer82 wrote:I am getting a lot of crashes running the latest beta on a Macbook Pro (Just trying to build my stage)

It seems to happen very early on when changing the position of the screen fixture, here is a section of the crash log.


I'm having the same crashes.

Its not always the same thread that crashes but it seems to be whichever one has the com.yourcompany strings.

Macbook is 10,1 2.4GHz, 8Gb running 10.9.

Cheers

Ben

benjo09

Posts : 3
Join date : 2014-01-11

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  Dave on Sat Jan 11, 2014 5:55 pm

Hi Guys

I've just updated the 7.1 BETA builds on the downloads section on this forum:

http://aiforum.forumotion.co.uk/t166-ai-v71-beta

Hopefully these are much more stable builds.  We're hoping the latest PC version is ready for official release on the www.avolitesmedia.com website as this has been tested at length by the Ai Team.  

The OSX version requires further BETA testing so please let me know if you spot any problems with this build.

Thanks & enjoy!
avatar
Dave
Admin

Posts : 267
Join date : 2012-11-14
Age : 39
Location : Avolites Media

View user profile http://www.immersive.eu

Back to top Go down

Re: Ai 7.1 BETA

Post  kurtpool on Fri Jan 17, 2014 11:13 pm

Hi Guys,

I've installed the Beta version on Mac to test, it seems stable but way more different of the PC version. I've never got any crash so far.

I've been trying output number 2 for see a 1920 image on a LED TV but I can't press the button.. Is there any reason for this button be disabled?

Also, I've noticed that a few "patches" are missing if we compare with the same version on PC platform.

Last one, Do you think we gonna have a AI for Mac (full version) anytime soon?

See you,

Kurtpool

kurtpool

Posts : 15
Join date : 2013-04-27
Age : 34
Location : Dublin

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Thu Jan 23, 2014 9:23 am

was the display connected before starting Ai?

there are a few bits not on the mac side yet due to a combination of differences between the two platforms and the greater amount of development time the windows side has had. the gap between the two will become less over time, but its fair to say that the windows side is currently a little ahead.
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

AI 7.1.0.483 and Sapphire Touch 7.2 Ai Crash

Post  pepiha83 on Sat Feb 01, 2014 3:20 am

AI 7.1 and CITP with lightning desk is not working at the Moment for us.
After connecting the Network cable, the AI software is crashing when the AI is reachable over network from the lightning console.
operating system is windows 7 X64
Is there any solution for this problem?
Thank you!

This is the according entry in the Windows Event log:

Protokollname: Application
Quelle:        Application Error
Datum:         31.01.2014 17:07:45
Ereignis-ID:   1000
Aufgabenkategorie:(100)
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      avolites-PC
Beschreibung:
Name der fehlerhaften Anwendung: Ai.exe, Version: 7.1.0.0, Zeitstempel: 0x52ce50a4
Name des fehlerhaften Moduls: Ai.exe, Version: 7.1.0.0, Zeitstempel: 0x52ce50a4
Ausnahmecode: 0xc0000005
Fehleroffset: 0x001b50da
ID des fehlerhaften Prozesses: 0xc18
Startzeit der fehlerhaften Anwendung: 0x01cf1e9e31378434
Pfad der fehlerhaften Anwendung: C:\Program Files\Avolites\Ai\Distrib\Ai.exe
Pfad des fehlerhaften Moduls: C:\Program Files\Avolites\Ai\Distrib\Ai.exe
Berichtskennung: d181fcdb-8a91-11e3-aa5f-00e05299e039
Ereignis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
 <System>
   <Provider Name="Application Error" />
   <EventID Qualifiers="0">1000</EventID>
   <Level>2</Level>
   <Task>100</Task>
   <Keywords>0x80000000000000</Keywords>
   <TimeCreated SystemTime="2014-01-31T16:07:45.000000000Z" />
   <EventRecordID>3446</EventRecordID>
   <Channel>Application</Channel>
   <Computer>avolites-PC</Computer>
   <Security />
 </System>
 <EventData>
   <Data>Ai.exe</Data>
   <Data>7.1.0.0</Data>
   <Data>52ce50a4</Data>
   <Data>Ai.exe</Data>
   <Data>7.1.0.0</Data>
   <Data>52ce50a4</Data>
   <Data>c0000005</Data>
   <Data>001b50da</Data>
   <Data>c18</Data>
   <Data>01cf1e9e31378434</Data>
   <Data>C:\Program Files\Avolites\Ai\Distrib\Ai.exe</Data>
   <Data>C:\Program Files\Avolites\Ai\Distrib\Ai.exe</Data>
   <Data>d181fcdb-8a91-11e3-aa5f-00e05299e039</Data>
 </EventData>
</Event>

pepiha83

Posts : 17
Join date : 2013-12-03
Location : Austria

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Sat Feb 01, 2014 7:47 am

unfortunately this one slipped past the net - we are aware of the problem, have adressed it and will complete the testing over the next few days, after which the new version will be uploaded.

appologies for this.
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

Re: Ai 7.1 BETA

Post  pepiha83 on Sat Feb 08, 2014 4:08 am

Hi!
Should our problem be fixed in the new build 489 on the website?

pepiha83

Posts : 17
Join date : 2013-12-03
Location : Austria

View user profile

Back to top Go down

Re: Ai 7.1 BETA

Post  ArranAI on Sat Feb 08, 2014 4:17 am

Hello,

the latest release on the website ( 7.1.0.489 ) is working properly with citp.
avatar
ArranAI
Admin

Posts : 318
Join date : 2012-11-15
Age : 41
Location : London

View user profile http://www.avolitesmedia.com

Back to top Go down

Re: Ai 7.1 BETA

Post  Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum